Having problems with Internet Explorer 7 or older operating systems

Support for Internet Explorer 7 has ended (not just by ourselves but also Microsoft, Google etc). You could try installing a different browser

https://www.google.com/intl/en/chrome/browser

or Firefox:

http://www.mozilla.org/en-US/firefox/new/

However, support for these browsers may already have ended if you're using an older operating system, such as Windows XP.

Due to the lack of security updates, we strongly encourage users on unsupported platforms to move to a newer operating system. This will ensure that you continue to receive the latest security updates and an up to date, compatible browser.

Still need help? Contact Kyero Contact Kyero